Logic Pro X and El Capitan

Logic Pro X and El Capitan

Logic Pro X works in OS X El Capitan. Bookmark this page for updates on third party plugins and hardware, like Native Instruments, Arturia, Universal Audio, and more.

UPDATE: OS X El Capitan 10.11.1 resolves an issue that prevents certain Audio Unit plug-ins from functioning properly.

I have a good reason why I usually upgrade to the latest Mac OS on the day of releases...

...because people want to know if Logic Pro works or not!

(It's usually best to refrain from updating your OS until the dust settles.)

You might want to bookmark this thread:
Mac Rumors: OS X El Capitan: Working & Not Working Apps

Share on Pinterest

, , , , , ,

29 Responses to Logic Pro X and El Capitan

  1. Jack Henderson October 1, 2015 at 5:20 AM #

    Thanks for the heads up Graham. Much appreciated.

  2. Parker October 2, 2015 at 2:47 AM #

    wow. I'm really glad you posted this. I'm right in the middle of recording my second record and this would potentially have been a huge and annoying setback. Thank you!

  3. Darren October 2, 2015 at 6:50 PM #

    Any news on Apogee Gio? They have released a new driver but I'm half tempted to go for it because it crashed everything in Yosemite.

  4. Denny October 25, 2015 at 2:11 AM #

    Any word on whether El Capitan works with Slate audio plug-ins?

    • Graham English October 27, 2015 at 11:01 AM #

      I tested the following plugins and they worked fine in Logic Pro X 10.2.0 and OS X 10.11.1: FG-X, Virtual Channel, Virtual MixBuss, SSD Sampler.

  5. ryan October 27, 2015 at 10:36 AM #

    Hi my Audio Interface (akai Pro) doesnt work with el capitan any news on when this will be done?

  6. Emo November 5, 2015 at 12:53 PM #

    Hi!
    Is El Captan compatible with the Universal Audio Apollo Twin?

    • Graham English November 6, 2015 at 5:43 PM #

      The Apollo Twin isn't officially compatible with El Capitan as of today (11-06-2015) but I'm having no problems with it.

  7. Roger Fahr November 30, 2015 at 3:53 PM #

    So El Capitan won't see my MBox2. Too bad.
    I am learning Logic Pro (10.2) and need an audio interface that will work with El Capitan.
    My set up is simple: acoustic/electric guitar and microphone (recorded separately).
    Was looking at the M-Track Plus, or M-Track Plus II.
    Any assistance/ recommendations appreciated.
    Thanks.

    • Graham English November 30, 2015 at 5:25 PM #

      I don't have any experience with M-Audio audio interfaces but I bet they'll do fine for most jobs. The interfaces you mentioned work with El Capitan.

    • matty December 12, 2015 at 11:31 AM #

      Ive got the Komplete Audio 6 which cost me £150 but its on sale for £140 now!!It depends what you want to spend and the quality?

  8. Rhison December 1, 2015 at 10:40 AM #

    i just downloaded el capitain and im about to download logic pro x next week. My question is the logic pro x says its not compitable with the new el capitain 10.11. Is this True or not?

    • Graham English December 3, 2015 at 9:30 AM #

      Where did you hear that? The specs in the app store say the minimum system requirements are OS X v10.9.5 or later (not to mention my post above that says "Logic Pro X works in OS X El Capitan." 🙂

  9. [email protected] January 2, 2016 at 10:20 PM #

    Logic Pro X no longer has 'prevent app nap' in get info I noticed - I'm using the latest El Capitan - so it automatically 'stays awake'.. is that right?

    • Graham English January 9, 2016 at 10:27 AM #

      "Prevent App Nap' has been disabled for Logic Pro X so if you want to ensure your computer stays awake, you'll need to adjust your Energy Saver settings in System Preferences.

  10. Xavier January 13, 2016 at 2:44 PM #

    I'm having issues with Logic Remote connecting with Mavericks so I figured finally updating to El Capitan would do the trick.....does this sound right?

    • Graham English January 25, 2016 at 9:38 AM #

      Logic Remote was just updated: Logic Remote 1.3 Update

      Apple doesn't list any Mac OS specs, just these:

      System Requirements
      Requires iOS 9.1 or later
      iPad support requires Logic Pro X 10.2.1, MainStage v3.2.3, or GarageBand v10.1
      iPad Pro support requires Logic Pro X 10.2.1 or MainStage v3.2.3
      iPhone support requires Logic Pro X 10.2.1

  11. Sean Luke January 18, 2016 at 11:25 AM #

    I've just upgraded to El Capitan on a new machine - fresh build in other words, then installed Logic and various other things. Compared to previous OS X releases El Capitan does seem a bit buggy, just more glitches and failures than I've ever had before. Copying a few regions from one part of a track to another causes Logic to crash - little things like that which aren't the end of the world but just annoying. I moved to Macs to get away from PCs which always seemd to do that kind of thing. Also my machine won't shut down now, I have to force it with the on/off switch - which isn't great for any O/S - answer seems to be to book a slot at a Genius Bar where they'll just trash your build and start again - but if I clear the user cache completely it shuts down no problem, very strange behaviour, not sure if anyone else has had that problem. I'd expect it maybe when upgrading a built machine from Mavericks or whatever but not on a brand new build. I hope this isn't the start of something bad for Apple machines.

    • Graham English January 25, 2016 at 9:40 AM #

      I would probably install from scratch again. Sounds like something went wrong during the installation.

  12. Carlo Salcedo April 2, 2016 at 10:04 AM #

    This may seem trivial to some, but i want a diff look for my Logic X. It's dark as it is. Is there anything out there for free that is safe to use and can be customized? The colors i mean.

    • Graham English May 2, 2016 at 3:19 PM #

      Google "logic pro x gui mods" - though I don't recommend or support it. Use at your own risk! 🙂

  13. Mr Kenny Pro May 23, 2016 at 12:43 PM #

    I just purchased the latest Logic Pro X recording software, and updated my IMac to El Capitan, only to find that most of the last recordings done in the Logic Pro version before the last one will not play in the last one I purchased.

    Can you help me here?
    I really have some nice music here, and I should love to continue editing them in the latest version of Logic Pro X!!

    HELP!!! HELP!!! HELP!!!

    • Graham English May 30, 2016 at 7:49 AM #

      I'm not sure exactly which versions of Logic Pro you're referring to. But the latest version of Logic Pro X should be able to import all previous Logic Pro X projects as well as Logic Pro 9 projects.

Leave a Reply